Page 1 of 11
Forum moderator: bigblog 
uCoz Community » For Webmasters » Custom Solutions » Problem with search (Search form not show in search page)
Problem with search
phuket
Posts: 22
Reputation: 0

Message # 1 | 4:57 PM
My site: http://koga-fansub.net/
I have 2 problem:

1. $SEARCH_FORM$ not show in search page (I place in header)
http://koga-fansub.net/search

2. Some entry not show in result when I search with $SEARCH_FORM$. I even created those entry 2 month ago, but they just show in $MODULE_SEARCH_FORM$

eg: when I search the word "aoharu"
http://koga-fansub.net/publ....-0-2278

and result:
Attachments: 5814930.jpg(33Kb)
Post edited by phuket - Sunday, 2015-09-13, 3:11 AM
Sunny
Posts: 9296
Reputation: 456

Message # 2 | 3:03 PM
1. You need to delete the following condition specified for the search form:

Code
<?if($URI_ID$="page1")?><?endif?>


2. The issue has been forwarded to the technical team.

I'm not active on the forum anymore. Please contact other forum staff.
phuket
Posts: 22
Reputation: 0

Message # 3 | 4:00 AM
Hi. Sunny
I removed this condition, but $SEARCH_FORM$ still not show
I even put $SEARCH_FORM$ directly in Site search > Search page, but it still not work sad
========================================================
I found one more problem, when I search with $MODULE_SEARCH_FORM$, I click on the result and one page show, but when I click to go back previous page, the problem come.
$IMAGE1$
Post edited by phuket - Wednesday, 2015-09-16, 2:22 PM
sejaspalma
Posts: 10
Reputation: 0

Message # 4 | 10:19 AM
Same problem here cry
Sunny
Posts: 9296
Reputation: 456

Message # 5 | 2:08 PM
Quote phuket ()
I removed this condition, but $SEARCH_FORM$ still not show
I even put $SEARCH_FORM$ directly in Site search > Search page, but it still not work


There are other conditions on the page as well. Please try to remove them and let me know if the problem persists.

Quote phuket ()
I found one more problem, when I search with $MODULE_SEARCH_FORM$, I click on the result and one page show, but when I click to go back previous page, the problem come.
$IMAGE1$


Please describe the issue in more detail.

sejaspalma, the same problem as what exactly? Please provide more details and the URL of your website.

I'm not active on the forum anymore. Please contact other forum staff.
phuket
Posts: 22
Reputation: 0

Message # 6 | 3:23 PM
Quote Sunny ()
There are other conditions on the page as well. Please try to remove them and let me know if the problem persists.

As you can see, this is the teample of search page. I put $SEARCH_FORM$ near $BODY$ with no conditions, right?
But this still not show in search page
Eg: http://koga-fansub.net/search/?q=test
Code

<html>
      <head>
   <meta charset="utf-8">
   <title>$SITE_NAME$ - $MODULE_NAME$</title>
   <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=2" />
   <link type="text/css" rel="StyleSheet" href="/_st/my.css" />
   <link href="https://plus.google.com/+KogafansubNetBlurayHeaven" rel="publisher" />
      </head>
        
      <body>
   <header>   
       $GLOBAL_AHEADER$   
   </header>
   <div id="casing">   
       <div class="part-a">   
    <!-- <middle> -->   
    <div id="content"><div class="wrapper">   
        <!-- <body> -->
        $GLOBAL_BANNER$
        <div class="sitesearch" style="width: 98%; background-color: #383838; padding: 1%;">
     $SEARCH_FORM$   
     $BODY$
        </div>
        <div align="center">$PAGE_SELECTOR$</div>
        <!-- </body> -->
        </div> </div>
    <!-- </middle> -->   
       </div>
   </div>
   $GLOBAL_BFOOTER$   
      </body>
</html>


Quote Sunny ()
Please describe the issue in more detail.


Eg:

Go to: http://koga-fansub.net/publ/vietsub/anime/84

1. Search "test" by $MODULE_SEARCH_FORM$



2. Open result



3. Press "Backspace" on keyboard or click back on browser



4. Problem:

Post edited by phuket - Thursday, 2015-09-17, 3:25 PM
bigblog
*boops*
Posts: 1472
Reputation: 71

Message # 7 | 3:35 PM
phuket, this is not a problem. This is a completely normal thing.
hey i'm joe, please don't call me on my real name because you're gonna misspell or mispronounce it and it drives me nuts
uCoz Community » For Webmasters » Custom Solutions » Problem with search (Search form not show in search page)
Page 1 of 11
Search: