Page 2 of 2«12
Forum moderator: bigblog 
uCoz Community » For Webmasters » Custom Solutions » Guide to install Let's Encrypt SSL Certificate (Step by Step Guide)
Guide to install Let's Encrypt SSL Certificate
Cyberdasm
Posts: 605
Reputation: 6

Message # 16 | 11:36 PM
Urs,
Quote Urs ()
There is no dot before underscore (copy paste text) on sslforfree.com AND if you put a dot like this ._acme-challenge the uCoz deletes the dot when you save !

It's my mistake... sorry there's no dot. I forget that I used it during my first attempt... Thank you for your feedback. Just continue without a dot I will amend it soon.

1F4BF3B

admin@lizeal.tk
www.lizeal.tk
fadly
Posts: 71
Reputation: 0

Message # 17 | 10:42 AM
Cyberdasm
Posts: 605
Reputation: 6

Message # 18 | 2:22 AM
Urs, Just save that as your back up. In case you redo your set-up. Such as your domain name expires something like that.
1F4BF3B

admin@lizeal.tk
www.lizeal.tk
Urs
Posts: 277
Reputation: 3

Message # 19 | 3:42 PM
I did it on namecheap.com using method 3 to attach a uCoz site.

You need there to put as HOST = _acme-challenge without the .www[domain.com]

It takes only 30 minutes for the files to get updated on namecheap.com !

Post edited by Urs - Thursday, 2017-06-22, 6:16 PM
bigblog
*boops*
Posts: 1430
Reputation: 67

Message # 20 | 11:25 PM
Urs, in Windows you can also open the Command Prompt (Win+R -> type "cmd" -> enter) and use the following command to check if the TXT record has been added:
Code
nslookup -q=TXT _acme-challenge.yourdomain.com

hey i'm joe, please don't call me on my real name because you're gonna misspell or mispronounce it and it drives me nuts
Staryte
Posts: 47
Reputation: 0

Message # 21 | 3:47 AM
Hellow, I followed all the steps and successfully uploaded manually and after a while the verification was successful too, but when I try to download certificate I get the page with the following information:

"Domain "www.staryte.com" challenge3 failed. Response from "https://acme-v01.api.letsencrypt.org/acme/challenge/Nsw_6fgdoQDVUHVN2MRyECbImTxdYKXS9NKQ-yb94oQ/1407343403" was: { "type": "dns-01", "status": "invalid", "error": { "type": "urn:acme:error:unauthorized", "detail": "Correct value not found for DNS challenge", "status": 403 }, "uri": "https://acme-v01.api.letsencrypt.org/acme/challenge/Nsw_6fgdoQDVUHVN2MRyECbImTxdYKXS9NKQ-yb94oQ/1407343403", "token": "-IaJcaNHrZXfz4-nzFvsaYcAQriOU5tRAiG-7dHUTfA", "keyAuthorization": "-IaJcaNHrZXfz4-nzFvsaYcAQriOU5tRAiG-7dHUTfA.ZOyNDgvLpWhnm8EaPchayAnBCJosJPiBpKTzSINhjHw" }"

What is the cause of the problem and how to solve?
Thanks.
bigblog
*boops*
Posts: 1430
Reputation: 67

Message # 22 | 8:11 AM
Staryte, maybe you rushed it and the DNS updates haven't got applied at the time you requested your certificate. Restart the process and use the command I mentioned in my previous post to check if the DNS settings are correct.
hey i'm joe, please don't call me on my real name because you're gonna misspell or mispronounce it and it drives me nuts
Cyberdasm
Posts: 605
Reputation: 6

Message # 23 | 2:39 AM
Staryte, bigblog was right. I recommend to redo it and don't rush. The problem is in the dns text record values since the values in your dns settings isn't the same values given in the SSLforFree. Take note that it will propagate in uCoz dashboard for a maximum of 4Hrs. How to compute? TTL / 60 (for seconds) / 60 (minutes) = waiting time that the settings would take effect.
Example: 14400/60=240 Minutes 240/60=4 Hours.
Another thing don't reload your browser it's because the values would change. To make it simple the dns text values is equivalent to token.

1F4BF3B

admin@lizeal.tk
www.lizeal.tk
Post edited by Cyberdasm - Monday, 2017-06-26, 2:42 AM
uCoz Community » For Webmasters » Custom Solutions » Guide to install Let's Encrypt SSL Certificate (Step by Step Guide)
Page 2 of 2«12
Search: