Page 1 of 11
uCoz Community » uCoz Modules » Forum » IMG tags parsing
IMG tags parsing
eDaniel
Posts: 23
Reputation: 0

Message # 1 | 11:34 PM
I don't know how the image tag/url parsing works in UCOZ forum module but it is giving me gray hairs. I'm getting tired of explaining to my users why some of the image links don't work in my forum. Initially I was editing every link manually but this is becoming an unbearable task. dry Here are some examples (some of these are non-existing, but just an example):

http://store2.data.bg/maranzano/CarAudio Proekti/Proekt Prelude 4th. gen/Proekt Prelude 4/DSC00873.JPG
http://media.snimka.bg/9675/025606063.jpg?r=2
http://www.randomwebsite.com/serveImage.php?img=image1.jpg
http://randomsite.com/ImageUI.WebResource.axd?imgid=52c538a0375e42278750e992c5beaa2e&type=jpg
http://i.ebayimg.com/20/!BzItP8!EGk~$%28KGrHqQOKk!E%29PPnozHvBMUrcZZ-nQ~~_12.JPG

Please advice wacko

preludebg.com / bulgarian honda prelude fanclub
Sunny
Posts: 9296
Reputation: 456

Message # 2 | 11:32 AM
eDaniel, please give more details as to what exactly you want to do and where you want to place these images.
I can say, that for example http://www.randomwebsite.com/serveImage.php?img=image1.jpg will work only if the website randomwebsite.com is created with uCoz and the PHP feature is enabled.

I'm not active on the forum anymore. Please contact other forum staff.
eDaniel
Posts: 23
Reputation: 0

Message # 3 | 12:40 PM
My users want to post images in their forum posts but in some cases the IMG tag does not work, and instead of image, we see the tag itself and its content.
One example is if the image URL contains encoded characters like %20 (whitespace). Another one is when the image is served through handler, and the last example is when there are query string parameters after the image url.
Most of the users are get used to the bb-forums where the same tag works flawlessly and therefore they ask me to fix the problem. I know I can use HTML img element but I don't want to give permissions for posting HTML code.

Real examples:
Code

[i_mg]http://store2.data.bg/maranzano/CarAudio Proekti/Proekt Prelude 4th. gen/Proekt Prelude 4/DSC00873.JPG[/i_mg]
[i_mg]http://media.snimka.bg/9675/025606063.jpg?r=2[/i_mg]
[i_mg]http://i.ebayimg.com/20/!BzItP8!EGk~$%28KGrHqQOKk!E%29PPnozHvBMUrcZZ-nQ~~_12.JPG[/i_mg]


Note: I renamed IMG to i_mg because your validation does not permit IMG tags here even in CODE block.

Added (2012-01-02, 6:40 AM)
---------------------------------------------
Happy new year!

Will you consider this as a feature request? Thanks.


preludebg.com / bulgarian honda prelude fanclub
Post edited by eDaniel - Tuesday, 2011-12-20, 9:09 AM
Paradox
Posts: 3276
Reputation: 145

Message # 4 | 6:04 AM
eDaniel, if you have a feature to request post the request in the correct board. As to the problem you have outlined there is no current workaround unless you use HTML. uCoz's image tag does work flawlessly for the purpose it was designed for, to display a reguar static image. This is only the second case this year where users have encountered this problem and I personally don't believe uCoz will look toward implementing this feature in the nearer future although it is not a complete impossiblity.

Happy New Year & Good luck wink

Developer, Designer, Communicator.
Been here for 6 years and counting.
Visit me at alexmoloney.me.
uCoz Community » uCoz Modules » Forum » IMG tags parsing
Page 1 of 11
Search: