Page 1 of 11
Forum moderator: Eriko 
uCoz Community » uCoz Modules » Photo Albums » Problem with adding entries on photo module
Problem with adding entries on photo module
Mar1aN
Posts: 186
Reputation: 3

Message # 1 | 5:13 PM
I set in cp that visitors can add photos, and they will appear only after my approval, but the entries appear on the site without my approval.
Why?

Post edited by Mar1aN - Sunday, 2014-01-05, 5:13 PM
Molly
Posts: 12
Reputation: 1

Message # 2 | 11:43 PM
Mar1aN, are you sure that you checked this field -> Pre-moderate new entries (must be verified) ↓, in options for user permissions?
Mar1aN
Posts: 186
Reputation: 3

Message # 3 | 0:03 AM
Paradox
Posts: 3276
Reputation: 145

Message # 4 | 4:55 AM
Mar1aN, could you please provide a site URL? Also - have you checked the action logs in the CP? They might give evidence as to what is happening to the entries. smile
Developer, Designer, Communicator.
Been here for 6 years and counting.
Visit me at alexmoloney.me.
Mar1aN
Posts: 186
Reputation: 3

Message # 5 | 3:29 PM
Paradox, i've checked !
The site is 2lol.ro .

Added (2014-01-06, 7:38 PM)
---------------------------------------------
Also the filters from photo module, after activation they don't appear on adding form and so can't use them.

Post edited by Mar1aN - Wednesday, 2014-01-08, 3:29 PM
Sunny
Posts: 9296
Reputation: 456

Message # 6 | 4:06 PM
Mar1aN, what groups have you enabled pre-moderation for? The members of which groups add photos that appear on the website without pre-moderation?

Quote Mar1aN ()
Also the filters from photo module, after activation they don't appear on adding form and so can't use them.


Please make sure you have the filter code, e.g. $FILTER1_MENU$ , in the templates.

I'm not active on the forum anymore. Please contact other forum staff.
Mar1aN
Posts: 186
Reputation: 3

Message # 7 | 4:33 PM
Quote
Mar1aN, what groups have you enabled pre-moderation for? The members of which groups add photos that appear on the website without pre-moderation?

Sunny, it's not from my settings,.

Quote
Please make sure you have the filter code, e.g. $FILTER1_MENU$ , in the templates.


The filter doesn't appear in the adding form ('/photo/0-0-0-1').
Attachments: 6046894.jpg(216Kb)

Post edited by Mar1aN - Thursday, 2014-01-09, 4:33 PM
Sunny
Posts: 9296
Reputation: 456

Message # 8 | 10:50 AM
Mar1aN, yeah, I can see that pre-moderation is enabled for Users. So, when a user adds a photo, do you see it as an admin or as a user? Because they will be displayed for you as the administrator, but other users won't be able to see them.

Quote Mar1aN ()
The filter doesn't appear in the adding form ('/photo/0-0-0-1').


Have you enabled the filter in the module settings -> Fields for adding photos?

I'm not active on the forum anymore. Please contact other forum staff.
Mar1aN
Posts: 186
Reputation: 3

Message # 9 | 12:15 PM
Quote Sunny ()
Mar1aN, yeah, I can see that pre-moderation is enabled for Users. So, when a user adds a photo, do you see it as an admin or as a user? Because they will be displayed for you as the administrator, but other users won't be able to see them.


Sunny, if a user adds a photo of course i can see her as as an administrator(with the moderation panel) but i can see her as well as an visitator/user.
Her is an video with the adding problem http://youtu.be/0J1IKza_qe0 .

Quote Sunny ()
Have you enabled the filter in the module settings -> Fields for adding photos?


Yes, i have it enabled .
Attachments: 3806550.png(35Kb)

Sunny
Posts: 9296
Reputation: 456

Message # 10 | 3:21 PM
Quote Mar1aN ()
Sunny, if a user adds a photo of course i can see her as as an administrator(with the moderation panel) but i can see her as well as an visitator/user.


Users can see photos because they are allowed to edit and remove their own entries. If you disable these permissions, the pre-moderation feature will work as you want it to.

Quote Mar1aN ()
Yes, i have it enabled


I was writing about the module settings:


I'm not active on the forum anymore. Please contact other forum staff.
Mar1aN
Posts: 186
Reputation: 3

Message # 11 | 3:40 PM
Quote Sunny ()
Users can see photos because they are allowed to edit and remove their own entries. If you disable these permissions, the pre-moderation feature will work as you want it to.


Sunny, i've unchecked "Edit own photos" and "Remove own photos" (for users), but Guests and Users can still add photos without my approval.
The difference is that now users can't acces the photo(PHOTO_URL) there added, but it's visible for visitors and users on the first page of photo module.

Quote Sunny ()
I was writing about the module settings:

Thank you, i forgot about that. biggrin

Post edited by Mar1aN - Friday, 2014-01-10, 3:54 PM
Sunny
Posts: 9296
Reputation: 456

Message # 12 | 11:55 AM
Quote Mar1aN ()
i've unchecked "Edit own photos" and "Remove own photos" (for users), but Guests and Users can still add photos without my approval.


I can't confirm the problem. Photos, added by Users and Guests are not available for viewing.

I'm not active on the forum anymore. Please contact other forum staff.
Mar1aN
Posts: 186
Reputation: 3

Message # 13 | 12:49 PM
Sunny, i was right there was a problem, but now the problem was solved in proportion of 80%, the remaining 20% has been included to the "To Do" list.

http://forum.ucoz.ro/forum/11-3131-2

uCoz Community » uCoz Modules » Photo Albums » Problem with adding entries on photo module
Page 1 of 11
Search: