PHP within uCoz
Posts: 3366
Reputation: 171

Message # 1 | 12:29 PM
The possibility to use limited PHP scripts was added for uCoz users in March 2011.

PHP is introduced for our users to have wider possibilities of website customization. In this way the websites will become more flexible and filled with various useful features. New functions will help to fulfill various tasks on the website, to use scripts for system modules interaction and data display in a proper place, their conversion. Opportunities of releasing unusual services on your websites will become available.

This solution won't work for portal system setup, monstrous forums and other high load scripts with a non-optimal source code. They create huge and useless load on the server.

As well:

  • You can find basic API usage manual here

How can you enable this service?

The service is available within paid plans: by default in the Maximal plan, and as an additional option to any other of the available plans for $1.99 per month.

All pricing plans are listed in Control panel -> $ Paid services -> Paid services

Please discuss it here. Share your knowledge and come up with structural suggestions.
Posts: 84
Reputation: 1

Message # 46 | 8:11 PM

I think your problem is not the user and password incorrect, but Client FTP settings.
Attachments: 0613680.png (81.8 Kb)

Hello! I am Ennio Sousa
Post edited by BraziluCoz - Sunday, 2016-01-17, 8:20 PM
Posts: 556
Reputation: 7

Message # 47 | 1:01 AM
BraziluCoz, the problem is not in my data (pasword or username) . Problem is on server, he just rejected my attempt to log in. I can log in to file manager with ftp but cant on php server. My both pasword is easy and readable so i just have to be blind to enter wrong pasword. Also, i did not touch anything (setings) on filezila. And this is not the first time to log in to php server,but it is first time that i cant log in whole week after payment.
I try many things but noting helped, i reinstaled filezila, changed pasword 15 times, reactivated paid package on cp, read tutorials on net, asked tech suport, writed here and from all i get the same answer
check pasword/username
. So, i listen to them, i check it, and i change it 15 times, but that's not the problem. And and still the same error

Status:    Disconnected from server
Status:    Resolving address of
Status:    Connecting to
Status:    Connection established, waiting for welcome message...
Status:    Insecure server, it does not support FTP over TLS.
Command:    USER eonlinebioskop
Response:    331 User eonlinebioskop OK. Password required
Command:    PASS **********
Response:    530 Login authentication failed
Error:    Critical error: Could not connect to server


Post edited by Ed05 - Monday, 2016-01-18, 1:06 AM
Posts: 1770
Reputation: 78

Message # 48 | 8:42 PM
Ed05, please try in another FTP client and tell me if the problem still persists.
hey i'm joe and i do not work for the company anymore, please contact other staff or tech support
icon by ch-chau

sometimes i lurk here
Posts: 556
Reputation: 7

Message # 49 | 5:52 PM
Sunny told that the problem was forwarded to tech suport. But here another ftp client named Cyberduck.The same error like on filezila.

Added (2016-01-19, 5:52 PM)
I cant hold my self not to ask this, how long time need to tech team check reported mailfunction,can we get exact time? Im asking cause i report this isue last week when i also pay for php,im afraid that after this long wait i will not get problem fixed but another queston related to problem. Also, the new php script wich i also buy at needs to be implemented on my site from last week, i promised to my users and they asking me every night where is it (option). It turned out that i lie them from 01-14 when i tought that when i activate new package i will get php after 24h but... wacko
Attachments: 0941669.png (50.2 Kb)

Post edited by Ed05 - Tuesday, 2016-01-19, 6:02 PM
Posts: 9296
Reputation: 456

Message # 50 | 1:22 PM
Ed05, I can't tell you the exact date, but I'll try to speed up the process.
I'm not active on the forum anymore. Please contact other forum staff.
Posts: 556
Reputation: 7

Message # 51 | 5:19 AM
If this meaning somethign,last time when i activated and deactivated optimal plan the php details was stil there even i did not have included in package.. So i think that some bug apeared. That was few month ago.
Attachments: 5519486.jpg (30.2 Kb) · 8913529.jpg (11.6 Kb)

Post edited by Ed05 - Thursday, 2016-01-21, 9:18 PM
Posts: 9296
Reputation: 456

Message # 52 | 3:25 PM
Ed05, the problem has been fixed. Please check.
I'm not active on the forum anymore. Please contact other forum staff.
Posts: 556
Reputation: 7

Message # 53 | 4:55 PM
Sunny, yes! It works now. Thanks.

Added (2016-02-26, 4:55 PM)
Im curious.. We are alowed to use/upload php files only in scripts folder on php server. The problem starts there, ucoz programers offer us their php scripts but every script have file config. But i already use two php scripts and one of them already use config file. Now i bought another php script but it have config file and if i want to upload it in scripts folder i must revrite it and in that way my other php option will stop to work (cause deletind original config file)
I try to upload files in new php folder wich i made but then i get error script data error couldnt find script location, system cant locate it but the path to it is correct. I also try to rename new config file but script wont work in that way. What could we do ?

Post edited by Ed05 - Friday, 2016-02-26, 4:57 PM
Old Guard
Posts: 3284
Reputation: 145

Message # 54 | 0:22 AM
Ed05, could you restructure your directory so that each script has its own individual directory structure within the root file system? Then link to the appropriate scripts within those respective directories? While still maintaining the controller outside of those directories to work around your script data error.

The error itself is unusual as I'm sure I've managed to do what you're explaining before. You're not trying to access any calls/methods that are banned by the system?

Let me know if any of this helps. happy

Jack of all trades in development, design, strategy.
Working as a Support Engineer.
Been here for 13 years and counting.
Posts: 556
Reputation: 7

Message # 55 | 7:06 PM
Paradox, that will work. I try some other way cause i was scared that some files wont find path to the script. Thanks.

Added (2016-04-10, 7:06 PM)
Php was in malfunction few min. Now its working. Thanks God server is up for now. happy
Attachments: 0287972.png (79.0 Kb)

Post edited by Ed05 - Sunday, 2016-04-10, 7:37 PM
Posts: 9296
Reputation: 456

Message # 56 | 2:02 PM
Ed05, yes, the PHP server was temporarily inaccessible. Should be working fine now.
I'm not active on the forum anymore. Please contact other forum staff.
Posts: 556
Reputation: 7

Message # 57 | 6:20 PM
Hello,its me again
Again there is problem with php on my site, its stop working. And all php functions failed. Sunny i sent you pm.

Why im having this problems with php from the beginning. First when i activated php it didn't work about week,now again. Server down, php down,i dont know what is next. I am without php from yesterday, i'm wondering why my users still visit my website after this failures.
But again,never mind,i just wish that you will fix this urgent and critical problem quickly cause, i will repeat, without php primary functions on the site do not work, which means that I will lose some users,again.
Attachments: 9622839.png (10.7 Kb)

Post edited by Ed05 - Thursday, 2016-05-05, 8:29 AM
Posts: 9296
Reputation: 456

Message # 58 | 1:50 PM
Ed05, I have replied to your PM.
I'm not active on the forum anymore. Please contact other forum staff.
Posts: 556
Reputation: 7

Message # 59 | 7:28 PM
There is huge problems on s26, i already reported server down but now when its up, php stop to work.
Im loosing my nervs ,but who cares.

Added (2016-06-13, 7:28 PM)
Ah, its working now.. What is next..we will se. dry

Post edited by Ed05 - Monday, 2016-06-13, 7:25 PM
Posts: 475
Reputation: 13

Message # 60 | 9:48 AM
I cannot login to my FTP PHP using Filezilla. I entered the correct host, username and password.

Please I need to login right now. But I can't?
Attachments: 3441352.png (69.7 Kb)