Page 1 of 261232526»
uCoz Community » uCoz Modules » Additional Features » Site search (And everything that is related to it)
Site search
Natashko
Posts: 3366
Reputation: 171
Message # 1 | 2:41 PM

uCoz Web Service has its own Site search.

You do not have to install this module. It is installed by default and it is a required module.
Attention: it is impossible to deinstall the Site Search module!

Though it is possible to set it up or not to use it at all.

You can select the modules to search in:


We would like to draw your attention to the setting

Supplement search results by tags with the results of site search:
If the checkbox is tagged, the site search results will be shown after the search results by tags.
Here is how the site search results will look for the request: CINEMA

And this is the way the search results by the tag CINEMA will look (You will see them in addition with site search results).

Where the first result is the search result by the tag CINEMA. And the rest of he results are site search results for the request CINEMA.
(This is an example with the default settings of Appearance of entries. "Entry brief description" in the modules is also disabled)


It is not difficult to distinguish the search results by the tag from the site search results. The appearance of the site search entries is the following: module name + the date (day-month-year the time of adding the entry).

The appearance of the search entries by the tag is the following: module name + the title of the module category (nesting depth of an entry. The code $ENTRY_DEPTH$ is responsible for that)+the date when the entry was added (day.month.year).

It is also possible to distinguish the search results by the tag from the site search results with a help of the URL of the request:

The appearance of the request URL of the site search results is the following: http://siteaddress/search/?q=
The appearance of the request URL of the search results by the tag is the following: http://siteaddress/search/

If the checkbox “Supplement search results by tags with the results of site search:” is not tagged:
the search by tag will show the results for the request of this tag only. And the site search will show the results on the search requests only.

Site search module has design customization feature.

Search page – will help you to customize the design of the page with the results of the site search and the search by tags.
Appearance of entries – will help you to customize the appearance of search results entries.

Sitemap

Sitemap is generated automatically on each website now. Users do not have to create it any more. Sitemap files are updated automatically, approximately once a day (depends on how often the website is updated). URLs of Sitemap files are written in the default robots.txt file, which we advise not to change.
You can get URLs of the Sitemap in Control panel->Site search
Note on search forms: each site module has codes $SEARCH_FORM$ and $MODULE_SEARCH_FORM$
It means that either the form for the indexed search on the whole website ($SEARCH_FORM$) or form to search entries of a module ($MODULE_SEARCH_FORM$) can be embedded into the template of the modules. Of course, both forms can be used simultaneously in order to search on the whole website or to search entries of a certain module.

Addition: on the websites with uID login, uNet users' bar has a site search form: Userbar->Control->Site search

Note:
  • The new entries are indexed within 10 days.
  • The entries that are deleted from the website, disappear from the search results within 14 days
  • In order to re-index the entries in the catalog manually, you need to tag the checkbox “Entry date:“ and Save without making any other changes.

See how to enable Site Search here:

Attachments: 4952405.png(26Kb) · 2896905.png(1Kb) · 7026367.png(7Kb) · 0944180.png(9Kb) · 8864910.png(2Kb)
con100
Posts: 11
Reputation: 0
Message # 2 | 2:41 PM
Activated the module and than added some tags to my files and wont work. I search for the tags I put and the search comes back empty with no results. Whats the problem? I split the tags up with commas but still no luck.
defaultNick9906
Posts: 3
Reputation: 0
Message # 3 | 2:41 PM
when i enter part of existing word in the search box i see:
"Results 0-0 of 0 for the request pic
Nothing found by the request"
Sunny
Posts: 9296
Reputation: 456
Message # 4 | 2:42 PM
con100, it is being fixed.
I'm not active on the forum anymore. Please contact other forum staff.
Blazer
Posts: 310
Reputation: 25
Message # 5 | 2:42 PM
defaultNick9906, provide your website link.
If i helped you + My Reputation and Give me an Award.
Ar7
Posts: 26
Reputation: 0
Message # 6 | 2:42 PM
Sunny site search still doesnt work
defaultNick9906
Posts: 3
Reputation: 0
Message # 7 | 2:42 PM
Quote (Blazer)
defaultNick9906, provide your website link.

http://emblab.ucoz.com/

when i try "pic24" it works
but for "pic" it doesn't

Armaros
Posts: 1424
Message # 8 | 2:42 PM
Quote (Ar7)
Sunny site search still doesnt work
Did you add search manually?
Natashko
Posts: 3366
Reputation: 171
Message # 9 | 2:42 PM
defaultNick9906, everything is fine with your search. It is just the way it works. It searches for the whole word and not its parts
Ar7
Posts: 26
Reputation: 0
Message # 10 | 2:42 PM
Quote (Armaros)
Did you add search manually?

I don't understand what you mean. I activated search in cp. I added tags to blogs, images, etc. Search doesn't work
defaultNick9906
Posts: 3
Reputation: 0
Message # 11 | 2:42 PM
Quote (Natashko)
everything is fine with your search. It is just the way it works. It searches for the whole word and not its parts

ok thanks,

but i need search system that works with part of the words.

can anyone give me some advice how can i do it (without employing web designer of course)???

Sunny
Posts: 9296
Reputation: 456
Message # 12 | 2:42 PM
Ar7, not all sites have been indexed by our search engine yet. And it's desirable to provide your website url so that I could check.
I'm not active on the forum anymore. Please contact other forum staff.
Natashko
Posts: 3366
Reputation: 171
Message # 13 | 2:42 PM
defaultNick9906,
Quote (defaultNick9906)
but i need search system that works with part of the words.

can anyone give me some advice how can i do it (without employing web designer of course)???


Unfortunately, it is not possible.
spongebob
Posts: 13
Reputation: 1
Message # 14 | 2:42 PM
Sunny,
Quote
...provide your website url so that I could check

I still have the same problem too, my site url is on the signature, could you please check it out for me too?

Bye,
Stefano


come and visit me at http://www.majinbu.ucoz.com/
amiko
Posts: 3
Reputation: 0
Message # 15 | 2:43 PM
Hello,

Doesn't work my site search engine. I'm trying with several variants, but it is not found anything. I don't understant what is wrong.

uCoz Community » uCoz Modules » Additional Features » Site search (And everything that is related to it)
Page 1 of 261232526»
Search: